August 16th, 2019 by Customer Care

The system requirements for SecureIT are as follows. SecureIT Plus Desktop is not currently available for Macs.

Android: IOS: Windows:
Version 6.0+ Version 9+ All 10 Editions
All 8 Editions
All 7 Editions – Service Pack 1 and above
  • Posted in
  • Comments Off on What are the operating system requirements?